Friday, September 28, 2012

Test Device Tango

With the release of iPhone 5 and Apple dropping support for arm v6 (so, effectively dropping support for anything that won't run iOS 4.3) we have to shuffle some things around.

The iPhone 3G and iPod Touch that were our lowest end devices will now be repurposed as music only devices or recycled. We considered selling them on eBay, but that seems cruel since they won't really work with apps.

We acquired an iPad 1 to use as the lowest end test device for iPads. It is running 5.1.1 and apparently will never get another meaningful upgrade from Apple. This means that we don't have an actual iPad that runs 4.3 and will have to rely on the simulator if any bugs appear. It is tempting at this point to set the minimum for all iPad projects to 5.1.1 since we don't trust the simulator for testing. We have an iPad "3" running iOS 6 as the other test device.

We are running iOS 6 on an iPhone 3GS which will become the main device to test performance. If an app runs well on that, it will be fine. We have an iPhone 4 with 5.1.1 installed to use to test any 5.x issues. In a few days, we will add an iPhone 5 with iOS 6 to round out the test devices.

As always, we keep an eye on David Smith's Version Stats to help guide our decisions about what to support. For all new projects, we are setting a minimum iOS level of 5.0 unless the client wants to target iOS 6 features. If Apple ever wanted to take a page from Google and show the versions of devices that have recently hit the App store, we would not complain.

No comments:

Post a Comment